SimPE + AccuTrans 3D = модель в мире

Содержание:

1. Как в SimPE достать модель из игры Sims 2.
2. Подготовка модели к AW в программе AccuTrans 3D.
3. Конвертируем текстуры.
4. Как достать модель из игры Sims 4 программой Sims 4 Studio.

Для работы нам понадобятся программы:

SimPE для работы с Sims 2.
Sims 4 Studio + Blenderдля работы с Sims 4.
Желательно русскоязычные версии. Легко ищутся в интернете, не требуют инсталяции и лекарства.
AccuTrans 3D - конвертор 3D объектов для Виртуальных миров Active Worlds. На странице программы выбирайте "Full Installation":
http://www.micromouse.ca/downloads.html

1. Как в SimPE достать модель из игры Sims 2.

Открываем SimPE. В меню ищем:
Файл - Открыть ►

Выбираем из списка как на рисунке ту игру, которая интересует нас.
посмотреть скриншот

В открывшемся окне с папками игры находим папку Objects там файл objects.package

Если вы хотите достать что-то из другой папки на вашем компьютере, например, не из игры, а закаченное из интернета, то выбирайте путь к нужному вам файлу *.package через
Файл - Открыть

Итак, открыли. Далее выбираем Object Workshop и в появившейся мастерской нажимаем Начать
посмотреть скриншот

Начнётся загрузка объектов в программу, возможно придется немного подождать.
Когда загрузка закончится, вы увидите список моделей, где выбираете то, что надо вам. Например, это будет Журнальный столик. Выбрав, жмём Далее.
посмотреть скриншот

Теперь выбираем Клонирование и жмём Старт.
посмотреть скриншот

Затем - Готово. В всплывшем окне нажимаем ОК. Программа предложит сохранить, значит мы сохраняем. Но нам в дальнейшем то, что сохранили не понадобиться, потому сохраняем куда-нибудь с расчётом это выкинуть потом.

В Дереве ресурсов находим (GMDC), в Списке ресурсов выбираем первую строчку, и переходим в PluginView.
посмотреть скриншот

Как видим, у нас есть много подобъектов, но отмечен только один. Из названий не отмеченных подобъектов следует, что это тени. Нам тени не нужны чаще всего, потому их не трогаем, а просто жмём Preview и смотрим, что там получилось.
посмотреть скриншот

А получился столик. Он-то нам и нужен. Нажимаем Export..., и сохраняем под любым удобным нам названием в формате obj.

Если там есть несколько подобъектов, то надо смотреть, одинаковые ли на них текстуры. Если текстура для модели одна, то всё сохраняем как есть. Если же текстур несколько, то подобъекты с разными текстурам надо сохранить отдельно, поснимав галочки со всех остальных подобъектов.

Бывает, что в предмете есть стекло, это видно, когда в названии фигурирует glass. Даже если оно не выделено галочкой, его надо выделить и сохранить отдельно, поснимав галочки со всех остальных подобъектов.

Ищем в Дереве ресурсов текстуры (TXTR). Опять смотрим, что их две, одна тень, другая то, что надо нам.
посмотреть скриншот

Текстуру тени игнорируем, а выбираем текстуру столика, нажимаем Export... и сохраняем как png.
посмотреть скриншот

Если есть в текстуре область с прозрачностью, то текстуру так в *.png и оставляем. Если этого нет, то *.png затем надо будет в любой удобной нам программе типа Фотошоп конвертировать в формат *.jpg. При экспорте из SinPE есть возможность сразу сохранить в *.jpg, но мы этого не делаем, потому что так текстура выходит из программы пережатой.

Если текстуры 2, значит на разные части объекта идут разные текстуры, и скорее всего в GMDC у вас будет не только один объект и тени к нему, а, например 2 или 3 подобъекта, обозначенных зелёной галочкой. Об этом написано выше.

Итак, базовую текстуру (текстуры) сохранили. Но, возможно, в игре есть ещё текстуры к этому же столику. Жмём Object Workshop, Назад, ещё раз Назад и выбираем не Клонирование, а Перекраска. Далее Старт, и опять сохраняем то, что потом подлежит выбрасыванию.

В результате всплывёт окно, где будут видны все имеющиеся к предмету текстуры. Предлагаю поочерёдно их сохранить. Выбираем нужную, жмём ОК. Переходим в PluginView - Export.... Сохранив так одну текстуру, идём за следующей: возвращаемся в Object Workshop, Назад, ещё раз Назад и выбираем Перекраска. Старт и опять сохраняем то, что потом подлежит выбрасыванию. И т.д.

Есть и другие пути к текстурам через эту программу. Если вы знаете их - делайте так, как удобно вам)

Итак, теперь у нас есть предмет и несколько текстур к нему.

2. Подготовка модели к AW в программе AccuTrans 3D.

File - Open
или
File - Open As - (*obj)
Открываем сохранённую модель в формате *.obj

Текстуру, которую мы к нему приготовили, надо назвать как-то приемлемо. Например, stolik01. А ещё лучше спросите у Хранителя мира как её назвать, потому, что может быть уже текстуры с таким названием в базе мира имеются.

Самое время её натянуть на столик. Жмём Edit Layers.
посмотреть скриншот

В появившемся окне ищем RenderWare.
посмотреть скриншот

Выделяем объект и ищем Browse for Texture.
посмотреть скриншот

Объект и текстура к нему должны лежать в одной папке! Выбираем нужную текстуру, жмём ОК и смотрим, насколько хорошо текстура легла на модель.

Если у нас не просто столик, а предмет, состоящий из нескольких частей, то их надо поочерёдно добавить в файл. Для этого открываем, допустим, первый из сохранённых подобъектов. Далее в меню жмём: File - Add New File

Если надо - ещё, и ещё. Потом эти части модели текстурим выше описанным способом нужными текстурами.

Если есть стекло, то на него лучше всего одеть специальную текстуру для стекла, проконсультируйтесь с Хранителем мира, какую лучше выбрать из имеющихся в базе.

Итак, текстуры на месте. Переходим к настройке света. Опять открываем Edit Layers. Ставим точку в Ambient, вписываем вверху 0,5, жмём Enter на клавиатуре.
посмотреть скриншот

0,5 теперь появится в настройке света модели. Если у нас не один объект, а несколько подобъектов, то 0,5 надо применить и к ним. Можно это сделать, поочерёдно выбирая подобъекты в списке. Но проще нажать значёк обведённый красным:
посмотреть скриншот

Далее в Diffuse выставляем точно таким же способом 0,7.
посмотреть скриншот

Настройки отражения света модели могут различаться в разных мирах AW. Для Sims2AW делаем так, для другого мира узнайте на месте как там принято делать.

Specular оставляем 0.
Opacity - это прозрачность. Нам надо 1,0. Так обычно и есть по умолчанию. Если у вас стекло, то на данный момент прозрачность ему задаётся специальной текстурой, надо только знать её название. Но можно и здесь в некоторых случаях.

Крайне редко, но порой надо активировать опцию Double Sided. При её активации текстура начнёт быть видна с внутренней стороны модели, по умолчанию она видна только с внешней. Просто так выбирать Double Sided не надо.

Если вы делаете телевизор, табличку для надписей или картинок, зеркало, то для той части модели, на которой будет изображение или текст, в графе Face Tag надо ввести цифру 200 для картинок или 100 для текста. Но текстура при этом должна распределяться по этой части модели ровно, целиком от края до края. Смотрите внимательно, если текстура не легла ровно, надо переходить в другие программы и править.
Для телевизора, зеркала, текстовой таблички для той части модели, где прописан Tag 200 или 100, можно выбрать настройки отражения света не 0.5-0.7, а 1.0-1.0. Тогда в мире эта часть модели будет выглядеть ярко и светло при любом освещении. Надо пробовать и смотреть как лучше и как принято в вашем мире.
Здесь же, в Face Tag можно назначить любой Tag любой части модели, допустим 2, 5, 10, 20, или 56. Но надо понимать зачем это делается и как впоследствии использовать такой приём при стройке.

Выбираем, что поставить в настройке Light Sampling: Facet или Vertex.
посмотреть скриншот

Facet оставит грани предмета четкими, а Vertex сгладит их. Если у вас дверь, стол, стул, то стоит выбрать Facet. Если подушка, мячик то Vertex. То есть надо пробовать и смотреть по ситуации.

Теперь всё готово, жмём ОК и выбираем в меню:
File - Save With Options.

Очень важно уменьшить в 10 раз размер объекта, так надо для миров. Ищем графу OSF Set To, пишем 0,1 и нажимаем кнопку OSF Set To. Так размер 0,1 выстроится по всем координатам.
посмотреть скриншот

И перед окончательным сохранением стоит сделать кое-какие настройки в параметрах сохранения:
посмотреть скриншот

посмотреть скриншот

Настроили, нажимаем Save и сохраняем.

Как посмотреть локально то, что получилось, изучайте тут:
http://xaoc.50webs.com/info/local/

Готовый файл можно открывать в Блокноте и при необходимости там что-то изменять, например, название текстур, настройки света.

3. Конвертируем текстуры.

Тестуры конвертируем в формат jpg. В программе Фотошоп проверьте нстройку в Редактирование - Настройка цветов. Там, в настройках рабочего пространства, в пункте "RGB" лучше выбрать sRGB IEC61966.

Размер текстур должен быть с величиной сторон 2, 4, 8, 16, 32, 64, 128, 256, 512, 1042. То есть 512х512, 128х128 и т.п. Если текстура вытянута в ширину, то могут быть аналогичные пропорции: 512х256, 1024х512 и т.п. Но если текстура вытянута в высоту, вертикальная, то очень важно на один пиксель увеличить её высоту. Иначе в мире она станет анимацией. Нельзя делать так: ширина 256, высота 512. Надо делать: ширина 256, высота 513. Или 512х1025, 256х1025, 64х257.

Размер стороны текстуры 2048 может быть и возможен, но лучше не делать. Уточните в мире, можно ли для вашей версии миров брать такие текстуры.

В игре Sims 4 обои для стен бывают трёх вариантов: низкая, высокая и самая высокая. Нам подходит самая первая, низкая. Если в исходном варианте пропорции 256х768 то приводим их к виду 256х513.

Текстуры для пола в мире могут отобразиться на моделях пола со сдвигом. Может быть стоит в Фотошопе применить фильтр Другое - Сдвиг, если текстура 512 то сдвиг 256.

Если есть в текстуре область с прозрачностью и вы оставляете текстуру в формате png, будьте внимательны и сразу посмотрите в локальном кеше как это всё выглядит в мире. Когда сетка модели состоит из нескольких частей, поищите варианты сведения к минимуму присутствие png на модели. Например, на стекло в дверце шкафа выбирайте png, а далее для самого шкафа сохраните текстуру как jpg. Текстуры png порой выдают в мире неприятные эффекты в виде "затирания" по краям модели, или, к примеру, у вас шкаф, внутри которого посуда как png, снаружи дверца со стеклом png, то посуда может быть не видна вообще.

4. Как достать модель из игры Sims 4 программой Sims 4 Studio.

В Sims 4 Studio нажимаем Объект - Создать на основе 3D. Выбираем модель, нажимаем справа внизу кнопку Далее, сохраняем файл package (он в дальнейшем нам не понадобится).

Когда модель станет видна, в закладках с правой стороны выбираем Текстура, ищем картинку тестуры и рядом с ней слева ищем Текстура со списком текстур в столбик (но скорее всего текстура будет одна), которые сохраняем как png. Бывает, вверху есть превью с различными вариантами текстур (например, разной расцветки), если они нужны, выделяем их поочерёдо и cохраняем. Но такое разнообразие скорее будет в тех сетах, которые вы скачали из интернета.

Переходим в закладку Сетки, там выбираем Экспорт сетки, сохраняем модель в формате blend. После сохранения модели и текстур нажимаем внизу справа Отменить, возвращаемся в исходное меню.

Для того чтобы достать модель из сета, который вы дополнительно скачали в интернете, выбираем в исходном меню Мои проекты. Ищем на компьютере файл package, который вы скачали, сохраняем из него текстуры, сетку.

Текстуры пола, стен из игры можно найти через кнопку Строить в основном меню программы. Если не срабатывает кнопка Строить или Объект, поищите другие версии программы, м.б. более ранние.

Для дальнейшей конвертации модели переходим в программу Blender, открываем сетку модели, экспортируем в фортмат obj.

С текстурой работаем далее в Фотошоп, с моделью в AccuTrans 3D как описано в основной части.